Commit 1079e457 authored by Christian Reuschling's avatar Christian Reuschling
Browse files

now lucene stuff is managed by DynaQ and not by leechcrawler. We are

independent from leechcrawler regarding the lucene version now. | some
new migrations to several dependency versions
parent 5ca3df8e
target
dynaq.keys
.idea
dynaq.iml
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>dfki.km.dynaq</groupId>
<artifactId>dynaq</artifactId>
<packaging>jar</packaging>
<version>2.4-SNAPSHOT</version>
<name>dynaq</name>
<url>http://dynaq.opendfki.de</url>
<developers>
<developer>
<name>Christian Reuschling</name>
<email>reuschling@dfki.uni-kl.de</email>
<organization>DFKI, KnowledgeManagement</organization>
<organizationUrl>http://www.dfki.de/web/forschung/km</organizationUrl>
</developer>
</developers>
<properties>
<maven.compiler.source>1.7</maven.compiler.source>
<maven.compiler.target>1.7</maven.compiler.target>
<j2seVersion>1.7</j2seVersion>
<maven.compiler.encoding>UTF-8</maven.compiler.encoding>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
<additionalparam>-Xdoclint:none</additionalparam>
<maven.build.timestamp.format>yyyy.MM.dd HH:mm</maven.build.timestamp.format>
</properties>
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>dfki.sds.dynaq</groupId>
<artifactId>dynaq</artifactId>
<packaging>jar</packaging>
<version>2.5-SNAPSHOT</version>
<name>dynaq</name>
<url>http://dynaq.opendfki.de</url>
<developers>
<developer>
<name>Christian Reuschling</name>
<email>reuschling@dfki.uni-kl.de</email>
<organization>DFKI, SDS department</organization>
<organizationUrl>https://www.dfki.de/en/web/research/research-departments/smart-data-knowledge-services/</organizationUrl>
</developer>
</developers>
<properties>
<maven.compiler.source>1.7</maven.compiler.source>
<maven.compiler.target>1.7</maven.compiler.target>
<!-- <j2seVersion>1.7</j2seVersion> -->
<maven.compiler.encoding>UTF-8</maven.compiler.encoding>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
<additionalparam>-Xdoclint:none</additionalparam>
<maven.build.timestamp.format>yyyy.MM.dd HH:mm</maven.build.timestamp.format>
</properties>
<distributionManagement>
<repository>
......@@ -42,7 +42,6 @@
<snapshotRepository>
<id>artifactory-libs-snapshots-local</id>
<url>http://www.dfki.uni-kl.de/artifactory/libs-snapshots-local</url>
<uniqueVersion>false</uniqueVersion>
</snapshotRepository>
</distributionManagement>
......@@ -59,612 +58,471 @@
</repositories>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>com.jgoodies</groupId>
<artifactId>jgoodies-common</artifactId>
<version>1.3.1</version>
<scope>compile</scope>
</dependency>
</dependencies>
</dependencyManagement>
<dependencies>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.8.2</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>de.dfki.km</groupId>
<artifactId>leechcrawler</artifactId>
<version>1.8</version>
<exclusions>
<exclusion>
<artifactId>asm-debug-all</artifactId>
<groupId>org.ow2.asm</groupId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>com.jgoodies</groupId>
<artifactId>jgoodies-binding</artifactId>
<version>2.6.1</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>org.apache.lucene</groupId> -->
<!-- <artifactId>lucene-core</artifactId> -->
<!-- <version>3.5.0-dynaq-patched</version> -->
<!-- <version>3.5.0</version> -->
<!-- </dependency> -->
<!-- <dependency> -->
<!-- <groupId>org.apache.lucene</groupId> -->
<!-- <artifactId>lucene-analyzers</artifactId> -->
<!-- <version>3.5.0</version> -->
<!-- </dependency> -->
<!-- <dependency> -->
<!-- <groupId>com.tangentum.phonetix</groupId> -->
<!-- <artifactId>phonetix</artifactId> -->
<!-- <version>0.2</version> -->
<!-- </dependency> -->
<dependency>
<groupId>org.javassist</groupId>
<artifactId>javassist</artifactId>
<!-- scheint zu gehen: -->
<!-- <version>3.17.0-GA</version> -->
<!-- <version>3.17.1-GA</version> -->
<!-- <version>3.18.0-GA</version> -->
<!-- <version>3.18.1-GA</version> -->
<version>3.18.2-GA</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-core</artifactId>
<!-- <version>3.5.0-dynaq-patched</version> -->
<!-- <version>3.5.0</version> -->
<!-- <version>4.9.0</version> -->
<version>4.9.0-dynaq-patched</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-analyzers-common</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-queries</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-queryparser</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-analyzers-phonetic</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-suggest</artifactId>
<version>4.9.0</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>org.apache.lucene</groupId> -->
<!-- <artifactId>lucene-spatial</artifactId> -->
<!-- <version>4.9.0</version> -->
<!-- </dependency> -->
<dependency>
<groupId>de.dfki.km</groupId>
<artifactId>inquisition</artifactId>
<version>23-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>de.dfki.km</groupId>
<artifactId>kafka</artifactId>
<version>23-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>de.dfki.km</groupId>
<artifactId>thumbnailer</artifactId>
<version>23-SNAPSHOT</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>dfki.km.delight</groupId> -->
<!-- <artifactId>xmlrpc-delight</artifactId> -->
<!-- <version>2.6.3</version> -->
<!-- </dependency> -->
<!-- <dependency> -->
<!-- <groupId>dfki.km.delight</groupId> -->
<!-- <artifactId>xstream-converter</artifactId> -->
<!-- <version>1.0.1</version> -->
<!-- </dependency> -->
<dependency>
<groupId>dfki.km.delight</groupId>
<artifactId>json-over-http-delight</artifactId>
<!-- <version>3.0-fluent-alpha1</version> -->
<version>3.0-fluent-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.1.0</version>
<!-- <scope>provided</scope> -->
</dependency>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>com.jgoodies</groupId>
<artifactId>jgoodies-common</artifactId>
<version>1.3.1</version>
<scope>compile</scope>
</dependency>
</dependencies>
</dependencyManagement>
<dependencies>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.8.2</version>
<scope>test</scope>
</dependency>
<!-- <dependency>-->
<!-- <groupId>org.junit.jupiter</groupId>-->
<!-- <artifactId>junit-jupiter</artifactId>-->
<!-- <version>5.7.1</version>-->
<!-- <scope>test</scope>-->
<!-- </dependency>-->
<!-- <dependency>-->
<!-- <groupId>org.junit.vintage</groupId>-->
<!-- <artifactId>junit-vintage-engine</artifactId>-->
<!-- <version>5.7.1</version>-->
<!-- <scope>test</scope>-->
<!-- </dependency>-->
<!-- leechcrawler-->
<dependency>
<groupId>de.dfki.sds</groupId>
<artifactId>leechcrawler</artifactId>
<version>1.25.1</version>
<exclusions>
<exclusion>
<artifactId>asm-debug-all</artifactId>
<groupId>org.ow2.asm</groupId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-io</groupId>
<artifactId>commons-io</artifactId>
<version>2.8.0</version>
</dependency>
<!-- leechcrawler-->
<dependency>
<groupId>com.jgoodies</groupId>
<artifactId>jgoodies-binding</artifactId>
<version>2.6.1</version>
<!-- <version>2.13.0</version>-->
</dependency>
<!-- <dependency>-->
<!-- <groupId>com.google.code.gson</groupId>-->
<!-- <artifactId>gson</artifactId>-->
<!-- <version>2.8.6</version>-->
<!-- </dependency>-->
<!-- <dependency>-->
<!-- <groupId>com.esotericsoftware</groupId>-->
<!-- <artifactId>kryo</artifactId>-->
<!-- <version>4.0.0</version>-->
<!-- </dependency>-->
<dependency>
<groupId>org.javassist</groupId>
<artifactId>javassist</artifactId>
<!-- scheint zu gehen: -->
<!-- <version>3.17.0-GA</version> -->
<!-- <version>3.17.1-GA</version> -->
<!-- <version>3.18.0-GA</version> -->
<!-- <version>3.18.1-GA</version> -->
<version>3.18.2-GA</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-core</artifactId>
<!-- <version>3.5.0-dynaq-patched</version> -->
<!-- <version>3.5.0</version> -->
<!-- <version>4.9.0</version> -->
<version>4.9.0-dynaq-patched</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-analyzers-common</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-queries</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-queryparser</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-analyzers-phonetic</artifactId>
<version>4.9.0</version>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-suggest</artifactId>
<version>4.9.0</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>org.apache.lucene</groupId> -->
<!-- <artifactId>lucene-spatial</artifactId> -->
<!-- <version>4.9.0</version> -->
<!-- </dependency> -->
<!-- <dependency>-->
<!-- <groupId>de.dfki.km</groupId>-->
<!-- <artifactId>inquisition</artifactId>-->
<!-- <version>23-SNAPSHOT</version>-->
<!-- </dependency>-->
<dependency>
<groupId>de.dfki.sds</groupId>
<artifactId>kafka</artifactId>
<version>1.3</version>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-plus</artifactId>
<version>9.2.7.v20150116</version>
</dependency>
<!-- <dependency>-->
<!-- <groupId>de.dfki.km</groupId>-->
<!-- <artifactId>thumbnailer</artifactId>-->
<!-- <version>23-SNAPSHOT</version>-->
<!-- </dependency>-->
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-annotations</artifactId>
<version>9.2.7.v20150116</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>dfki.km.delight</groupId> -->
<!-- <artifactId>xmlrpc-delight</artifactId> -->
<!-- <version>2.6.3</version> -->
<!-- </dependency> -->
<!-- <dependency> -->
<!-- <groupId>dfki.km.delight</groupId> -->
<!-- <artifactId>xstream-converter</artifactId> -->
<!-- <version>1.0.1</version> -->
<!-- </dependency> -->
<dependency>
<groupId>dfki.km.delight</groupId>
<artifactId>json-over-http-delight</artifactId>
<!-- <version>3.0-fluent-alpha1</version> -->
<version>3.0-fluent-SNAPSHOT</version>
</dependency>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>javax.servlet-api</artifactId>
<version>3.1.0</version>
<!-- <scope>provided</scope> -->
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-plus</artifactId>
<version>9.2.7.v20150116</version>
</dependency>
<dependency>
<groupId>javax.jmdns</groupId>
<artifactId>jmdns</artifactId>
<version>3.4.1</version>
</dependency>
<dependency>
<groupId>org.eclipse.jetty</groupId>
<artifactId>jetty-annotations</artifactId>
<version>9.2.7.v20150116</version>
</dependency>
<dependency>
<groupId>info.clearthought</groupId>
<artifactId>tablelayout</artifactId>
<version>2007-04-21</version>
</dependency>
<dependency>
<groupId>org.jasypt</groupId>
<artifactId>jasypt</artifactId>
<version>1.9.0</version>
</dependency>
<dependency>
<groupId>net.sf.opencsv</groupId>
<artifactId>opencsv</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>org.piccolo2d</groupId>
<artifactId>piccolo2d-core</artifactId>
<version>1.3.1</version>
</dependency>
<dependency>
<groupId>org.piccolo2d</groupId>
<artifactId>piccolo2d-extras</artifactId>
<version>1.3.1</version>
</dependency>
<dependency>
<groupId>org.artofsolving.jodconverter</groupId>
<artifactId>jodconverter-core</artifactId>
<version>3.0-dfki-released</version>
</dependency>
<dependency>
<groupId>javax.jmdns</groupId>
<artifactId>jmdns</artifactId>
<version>3.4.1</version>
</dependency>
<dependency>
<groupId>info.clearthought</groupId>
<artifactId>tablelayout</artifactId>
<version>2007-04-21</version>
</dependency>
<dependency>
<groupId>org.jasypt</groupId>
<artifactId>jasypt</artifactId>
<version>1.9.0</version>
</dependency>
<dependency>
<groupId>skinlf</groupId>
<artifactId>skinlf</artifactId>
<version>1.2.3</version>
</dependency>
<dependency>
<groupId>org.prefuse</groupId>
<artifactId>prefuse</artifactId>
<version>beta-20071021</version>
</dependency>
<dependency>
<groupId>net.sf.opencsv</groupId>
<artifactId>opencsv</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>org.piccolo2d</groupId>
<artifactId>piccolo2d-core</artifactId>
<version>1.3.1</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>org.apache.mahout</groupId> -->
<!-- <artifactId>mahout-integration</artifactId> -->
<!-- <version>0.9</version> -->
<!-- </dependency> -->
<dependency>
<groupId>org.piccolo2d</groupId>
<artifactId>piccolo2d-extras</artifactId>
<version>1.3.1</version>
</dependency>
<dependency>
<groupId>org.artofsolving.jodconverter</groupId>
<artifactId>jodconverter-core</artifactId>
<version>3.0-dfki-released</version>
</dependency>
<!-- <dependency> -->
<!-- <groupId>org.apache.mahout</groupId> -->
<!-- <artifactId>mahout-examples</artifactId> -->
<!-- <version>0.9</version> -->
<!-- </dependency> -->
<!-- <dependency> -->
<!-- <groupId>org.apache.lucene</groupId> -->
<!-- <artifactId>lucene-facet</artifactId> -->
<!-- <version>4.9.0</version> -->
<!-- </dependency> -->
</dependencies>
<dependency>
<groupId>skinlf</groupId>
<artifactId>skinlf</artifactId>
<version>1.2.3</version>
</dependency>
<dependency>
<groupId>org.prefuse</groupId>
<artifactId>prefuse</artifactId>
<version>beta-20071021</version>
</dependency>
</dependencies>
<!-- dummy for buildnumber plugin -->
<scm>
<connection>scm:svn:http://127.0.0.1/dummy</connection>
<developerConnection>scm:svn:https://127.0.0.1/dummy</developerConnection>
<tag>HEAD</tag>
<url>http://127.0.0.1/dummy</url>
</scm>
<build>
<build>
<plugins>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>appassembler-maven-plugin</artifactId>
<version>1.10</version>
<configuration>
<assembleDirectory>${project.build.directory}/assembleDir</assembleDirectory>
<extraJvmArguments>-Xmx2G</extraJvmArguments>
<binFolder>bin</binFolder>
<repositoryName>lib</repositoryName>
<repositoryLayout>flat</repositoryLayout>
<useAsterikClassPath>true</useAsterikClassPath>
<projectArtifactFirstInClassPath>true</projectArtifactFirstInClassPath>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>appassembler-maven-plugin</artifactId>
<version>2.1.0</version>
<configuration>
<assembleDirectory>${project.build.directory}/assembleDir</assembleDirectory>
<extraJvmArguments>-Xmx2G --add-opens java.base/java.lang=ALL-UNNAMED --add-opens java.desktop/sun.awt.dnd=ALL-UNNAMED</extraJvmArguments>
<binFolder>/bin</binFolder>
<repositoryName>lib</repositoryName>
<repositoryLayout>flat</repositoryLayout>
<useWildcardClassPath>true</useWildcardClassPath>
<projectArtifactFirstInClassPath>true</projectArtifactFirstInClassPath>
<binFileExtensions>
<unix>.sh</unix>
</binFileExtensions>